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1. General Description 
 
CurveAnalyzer software implements: 

� variuos single functions, that can be used for specific airfoil evaluations 
� a special “all-in-one” function for automatic evaluation of a single airfoil section. 
� special tool for generating measurement path when using PC-DMIS measurement s/w 

 

2. Single functions for specific airfoil calculatio n 
 
The usage of this functions is generally for “manual” analysis of a section or for a prepartion of the 
nominal data. They can be also included in a  CA “macro”, but it is definetely easier to use the 
special “all-in-one” function, that allows to perform the evaluation task, including the preparition of 
the report with few clicks. 
 
The single functions for specific airfoil calculations are: 
 

2.1 Airfoil parameters calculation 
 
Function Access 
Airfoil parameters calculation Curve -> Airfoil calculations -> Airfoil parameters 

calculation 
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Airfoil Section – here all available CRV object in CA are shown. You are allowed to select one or 
more curves. 
 
Leading Edge direction – here we can select the direction of the LE. It is possible to leave it on 
“auto” or to select explicitely the direction of the LE respect to the co-ordinate axises. If leaving on 
“auto” the following rule will be applied : CA will calculate the MCL nad the Max. Thickness 
position. The edge that results to be closer to the postion of the Max. Thickness will be the LE. As 
this rule is not valid for all airfoil sections, in those cases you must use the explicit indication of the 
direction of the TE. 
 
LE/TE % - this input regards the length of the LE/TE, expressed as percantage of the length of the 
MCL. 
 

 Different Calculatios -  the following calculation can be selected: 
 
Maximum diameter Calculates the postion of the Max. Thickness and its value, so a 

CIR object will be created with the diameter that is equal to the 
max. thickness. 

Mean camber line (MCL) Creates a CRV object with a fixed number of 100 points on the 
MCL 

Pierce points on MCL Creates two points (PNT objects) – one on the LE and another 
one on the TE, build on the imaginary “pierce” point of the 
MCL with the profile 

Contact line Creates contact line (LIN object) on the concave side of the 
profile 

Caliper points Creates two points (PNT objects), that are build respect to the 
calculated contact line and that determine the chord length 

Separate segments If enabled, this option will create four new CRV objects, each of 
them will contain point on the LE, TE, concave side and convex 
side. 

 
Note on usage: The usage of this functions is supposed to be in the manual analysis /checking of 
airfoil sections, or for reverse engineering purposes. 
 
Select All / Deselect all – two buttons used for fast selection/deselction of all options 
 

 Point density re-calculation: 
 
If using this tab it will be possible to re-generate points on the spline build through the given points, 
assigning to each part of the sections (LE, TE, concave and convex side) certain ammount of points. 
This function is not guaranteed to produce the exact number of points, working with tolerance of +/-
1 point. 
 
Notes on  usage: The usage of this functions is supposed to be in the prepartion of the nominal 
sections.The calculation  may take significant time! 
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2.2 Edge thickness 
 
Function Access 
Edge thickness calculation Curve -> Airfoil calculations -> Calculate Edge Thickness 
 
 

 
 
 
Airfoil Section – here all available CRV object in CA are shown. You are allowed to select one or 
more curves. 
 
Leading Edge direction – here we can select the direction of the LE. It is possible to leave it on 
“auto” or to select explicitely the direction of the LE respect to the co-ordinate axises. If leaving on 
“auto” the following rule will be applied : CA will calculate the MCL nad the Max. Thickness 
position. The edge that results to be closer to the postion of the Max. Thickness will be the LE. As 
this rule is not valid for all airfoil sections, in those cases you must use the explicit indication of the 
direction of the TE. 
 
Options – you can select which thickness will be calculated and at which distance (expressed in the 
current unit). If selecting also “Create dimension” check box, corrsponding dimension will be 
created. The internal procedure of calculating the thickness is as following : the MCL is calculated, 
so the LE/TE points are found. On the LE/TE points circles with given radius are calculated (using 
the distance input from the interface), then the MCL line is intersected with these circles. On the 
intersection points a line is created that is orthoganal to the MCL curve for that point. Using this 
line and the profile, two intersection points on the profile are calculates. The 2D distance between 
those points is the edge thickness. 
 
 
Note on usage: The usage of this functions is supposed to be in the manual analysis /checking of 
airfoil sections, or for reverse engineering purposes. 
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2.3 Edge radius 
 
Function Access 
Edge radius calculation Curve -> Airfoil calculations -> Calculate Edge radius 
 
 

 
 
 
Airfoil Section – here all available CRV object in CA are shown. You are allowed to select one or 
more curves. 
 
Leading Edge direction – here we can select the direction of the LE. It is possible to leave it on 
“auto” or to select explicitely the direction of the LE respect to the co-ordinate axises. If leaving on 
“auto” the following rule will be applied : CA will calculate the MCL nad the Max. Thickness 
position. The edge that results to be closer to the postion of the Max. Thickness will be the LE. As 
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this rule is not valid for all airfoil sections, in those cases you must use the explicit indication of the 
direction of the TE. 
 
Options – you can select which radius will be calculated and what arc segment do you want to use 
(expressed in degrees). If selecting also “Create dimension” check box, corrsponding dimension 
will be created. The internal procedure of calculating the radiuses is as following : the MCL is 
calculated, so the LE/TE points are found. Iterations are performed, with points that are 
symmetrically disposed arroun the LE or TE, until the calculated circle results to be constructed 
with points that have arc segment above the limitr set by the user. This last circle is retained to be 
valid for the edge radius. 
Note on usage: The usage of this functions is supposed to be in the manual analysis /checking of 
airfoil sections, or for reverse engineering purposes. 
 

 

2.4 Assign tollerances to nominal 
 
Function Access 
Assign tolerances to nominal Curve -> Airfoil calculations -> Assign tolerances to 

nominal 
 

  
 
The purpose of this function is to assign fixed or variable tolerance to the airfoil section in 
extremely fast way. Note that this is essential step, when preparing the nomonal sections that will be 
later used in the “all-in-one” function. Keep in mind that if needed you can use the general methods 
of assigning tolerance for the curves, those you are allowed to create any possible tolerance filed. 
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This function also automatically declares the CRV to be “closed” and calculates the vectors as for 
external curve. 
 
Airfoil Section – here all available CRV object in CA are shown. You are allowed to select one or 
more curves. 
 
Leading Edge direction – here we can select the direction of the LE. It is possible to leave it on 
“auto” or to select explicitely the direction of the LE respect to the co-ordinate axises. If leaving on 
“auto” the following rule will be applied : CA will calculate the MCL nad the Max. Thickness 
position. The edge that results to be closer to the postion of the Max. Thickness will be the LE. As 
this rule is not valid for all airfoil sections, in those cases you must use the explicit indication of the 
direction of the TE. 
 
LE/TE % - this input regards the length of the LE/TE, expressed as percantage of the length of the 
MCL. 
 
Tolerance values : to be inserted according to the selected tolerance type 
 
Note on the usage: The usage of this functions is supposed to be in the preparation of the nominal 
sections. 
 

2.5 Collect airfoil scans 
 
Function Access 
Collect airfoil scans Curve -> Airfoil calculations -> Collect airfoil scans 
 

 
 
This function collects two measured curves (typically with overlay), producing as output one 
profile. This method is the most common one when working with measured sections. If the section 
is composed by more scans (as it happens in MBR’s), you would use the common “Curve -> 
Collect curves function, using probably also the sorting option) 
 
Curve 1 / Curve 2 : List of the all available curves in CA. You must select two curves that belong 
to the same section. The graphical field nearby will help you to check if you have selected  the 
sections correctly. 
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Options : In this field you can selectto “sort” the points (that is to re.order them to avoil loop-
backs) and eventually to remove very close points. It is strongly recomended that you use this 
function when having bhigh point density. If the data arrive from a measuring device with low point 
density, it may happen that the sorting will order badly some points. In this cases you should not 
use the “sorting” option. 
 
Note on the usage: The usage of this functions is supposed to be in the preparation of the measured 
section from two scans on the concave and convex side. It is a usual step to be recorded in CA 
evaluation” macro”. 
 

2.6 Generate Meas. Path on airfoil 
 
Function Access 
Airfoil path generation Measure -> Generate path for airfoil 
 
Attention : this function can be used ONLY if using CA with PC-DMIS measuring s/w. It allows to 
generate scans in a opened PC-DMIS  PP, from the side indicated by the user. This simplifies 
extremely the prepartion of the PP. The pre-requistie for doing this operation is the presence of the 
nominal section in CA and opened PC-DMIS PP with the alignment already done. 
 

 
 
In the inteface window you can select the position of the probe (in the PC-DMIS PP you must use 
accordingly some MOVE commands are some RECALL TIP commands in order to prepare the 
CMM for the measurement). Then you can selectthe measurement mode (by scan or single points). 
The “MOVE” option creates 2 moves before and after the scan at the distance indicates along the 
direction of the tip (as indicated in the inteface window!). 
 
If scan is selected it is possible to adjust the scan speed and point density separately for the edges 
and for the sides. The “overtravel” value indicates the ammount of the scan”extension” over the 
physical limit of the section (this guarantees that the 2 scans will intersect well). 
 
In the Lsit box you can select one or more section. Clicking on GENEREATE commands will be 
generated at the current cursor position in PC-DMIS. 
 
Typically after finishing one side, we move the CMM manually to the other side, then just reverse 
the direction of the probe (you can use the “<->” button) and generate the rest of scans. 
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3. Generic functions having relation to the airfoil  calculation 
 
Thera are also some general purpose functions, often used when working with Airfoils sections. In 
this section we list some of them. 
 

3.1 Curve calculation 
 
Function Access 
Curve calculation Curve -> Curve 2D calculation 
 

 
 
The mostly interesting options in this function are the follwoing : 
 
Eliminate points closer than – allows to remove “equal” points performing a “cleaning” action 
over the curve 
Chordal error filter – applies chordal filter on the points. Usually this function is used to reduce 
the ammount of the nominal points. The points with chordal error lower than the indicated one will 
be removed, but only in case that they are a a distance smaller than the indicated “Min distance” 
value. Typical input for “medium size” airfoil section (chord 100 mm) woul be : chord error = 
0.001, Min distance = 1. 
 
For more info on that function refer to the on-line help of CA 
 
Note on the usage: The usage of this functions is supposed to be in the preparation of the nominal 
sections. 
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3.2 Radius correction 
 
Function Access 
Radius compensation Curve -> Offset 
 

 
 
Used to offset the curve in case that it is not radius compensated. Please refer to the on-line help for 
details on this function. 
 
Note on the usage: The usage of this functions is supposed to be in the preparation of the measured 
section from a not radius compensated scan.. It can be a  step to be recorded in CA evaluation” 
macro”. It is anyway not absolutely necessary, because the “all-in-one” function already has this 
option in the “pre-processing” option. 
 

4. The “all-in-one” function for evaluating of airf oil sections 
 
Function Access 
Airfoil evaluations Utilities -> Calculation Utilities -> Airfoil evaluations 
 
The “all-in-one” functions allws to perform complete evaluation on airfoil section, producing also 
reporting page of it. In order to be recalled you musthave in CA the following curves: 
 

� nominal sections 
� measured sections (can be radius corrected or not), must be complete sections 
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The function will perform all necessary 
 

� form error evaluation (examples for the complete profile, LE, TE) 
 

   
 
 

� airfoil parameter calculations listed as dimension with their tolerances 
 

 
 
 
Regarding the available Best-fit algorithms, the following fits are available: 

- no fit 
- LSQ on the whole profile 
- LSQ on the profile without TE 
- LSQ on the whole profile without LE/TE 
- 2 points fit on 10% of the MCL 

The edges can be evaluated using the global fit, or applying a local LSQ fit. 
 
The following parameters can be calculated and reported 
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- Maximum thickness value D 
- Position of the maximun thickness XD,YD 
- Point of the gravity of the section XS,YS  
- Chord length (with different algorrithms) LP 
- Angle of the chord Beta_Bi2 (with different algorithms) 
- Edge thckness (LE/TE) 
- Stack X/Y and rotation values, resulting from the fit 
- Max/Min points respect to the axises (in the example X MIN / Y MAX) 
- True position of the stack axis 

 
 
Options present in this function: 
 

 
 

 
 
 
Nominale/Measured profiles - Here you are allowed to select the 
nominal and the measured curve (in the lists all available curves in 
CA are shown). Both curves must decribe fully the profile. The 
selected curves will be shown in the graphical field bellow 
 
Leading Edge direction – here we can select the direction of the LE. 
It is possible to leave it on “auto” or to select explicitely the direction 
of the LE respect to the co-ordinate axises. If leaving on “auto” the 
following rule will be applied : CA will calculate the MCL nad the 
Max. Thickness position. The edge that results to be closer to the 
postion of the Max. Thickness will be the LE. As this rule is not 
valid for all airfoil sections, in those cases you must use the explicit 
indication of the direction of the TE. 
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Pre-processing of the measured data – according to the status of 
the measured data we can request different pre.processing options: 

- Sorting of points – will re-order the points. Typically it is not 
needed and in any case, if having low point density should 
not be done 

- Removing “equal” points – will remove point closer than the value indicated 
Note: if the measured data are obtained by “Collect Aitrfoil sections” function, it is not needed to 
activate any of the above options.  

- Radius compensation – if the measured data are not radius compensated, input the value for 
the radius compensation (radius of the probe) 

 
Global Form options – set-up the parameter for the form 
evaluation of the complete profile: 

- Show – allows to select which part of the airfoil section 
will be shown in the “Global” view. You can select 
between showing the whole profile, the profile without 
TE (suitable for thick profiles with thin TE), or the profile 
without TE and LE (suitable for very thin profiles, or whenever the evaluation of the LE/TE 
is not desired, because the edges are “square”. 

- Best-fit apply on – here you can select which type of best-fit to use for the “Global” fit. The 
current options are : No Fit, LSQ fit on the whole profile, LSQ fit on the profile without TE, 
LSQ fit on the profile without TE, fit on 2 points on MCL (10%) 

- Best-fit type – visible anly if some fit is selected – allows to select between 
Rotate&Translate, Rotate only, Translate only options 

- Fit considers the avreage deviation – This check-box actiavtes a special function that will fit 
the measured profile not on the nominal one, but will first look for the average deviations, 
then will build internally a new nominal for fitting, that will be offsetted respect to the 
original nominal at the value of the average deviation found. This option is usefull for 
“thick” profiles, where the length of the convex side is significantly longer than the length of 
the concave side, and at the same time we have measured profile that has significant 
“excess” of material. 

- Amp / Zoom – amplification applied on the deviations and the zoom factor applied to the 
profiles.  
* For the Amplification:If inserted with “-“ sign will not show spikes. See the examples 
bellow: 

 
Amp=15    Amp=-15 

    
 

Anyway for the color coding (colouring of the deviations) the general setting of the color 
schema will be used. This setting can be changed from “Edit” -> “Preferences” 
* For the Zoom : If set  to “0” (standard setting) the zoom will be automatic, in order to fit 
the profile inside of the available view. Otherwise you can input the desired zoom factor 
(negative numbers are not allowed and will cause the zoom to be automatic) 

- Axis display – you can select between not showing the axises, or showing them in the origin 
point, or in the lower right corner of the graphical field 
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- Other display options – you can request that the MCL line, the Max. Thickness circle and/or 
the contact line must be shown 

 
 

Edge Form options – set-up the parameter for the form evaluation of the complete profile: 
 

   
 
Here we can select how the edges will be evaluated (generaly we can de-activate this calculations at 
all – for axample in case that the edges do not need to be evaluated at all) 
 

- Best-fit – you can select bewteen using the “Global” fit (in this cases the form error will be 
essentially the same as in the global view, but the edge will be just “zoomed”), or you can 
use a local fit option (that will detach the edge and will fit it indipendently to the nominal). 
In this second case, the user can select between using the tolerance from the nominal, or 
type a specific tolerance. This option is used when over the whole profile we have a 
tolerance field that considers also the “chord” length tolerance and is quite large in the edge 
areas. Using the local fit in this case we would input significantly smaller tollerance fro the 
form error. 

- Amp / Zoom – amplification applied on the deviations and the zoom factor to be applied to 
the profile. For more info look at the description of the same setting for the “Global form 
options”.  

- Axis display – you can select between not showing the axises, or showing them in the origin 
point, or in the lower right corner of the graphical field 

 
Esiste la possibilità di non effettuare questi calcoli (puo’ rendersi necessario disattivare questi 
calcoli se per esempio il bordo per il suo carattere non è stato misurato bene – esempio: bordi non 
raggiati) 
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Airfoil parameters – here we can select which kind of calculation is needed, and eventually the 
requested algorithm and some additional parameters. After selecting those parameters you can click 
on “Calculate Nominals” – this will launch a procedure that calculates the parameters from the 
nominal section selected. If needed you can correct those nominals manually. 
  

 
 
Max Thickness D : value of the max. thickness 
 
Posistion of the Max Thickness XD – XPosition of the maximum thickness circle 
 
Posistion of the Max Thickness YD – Y Position of the maximum thickness circle 
 
Gravity XS  – YPosition of the point of gravity,calculated on the section 
 
Gravity YS – Y Position of the point of gravity,calculated on the section   
 
Chord angle – chord angle calculation (linee between LE/TE points or on the contact line). It is 
also possible to insert offset angle, that will be added to the calculated ones.  
 
Chord Length – calculates the chord length accordingto the selected algorithm 
 
Edge thickness – calculates the edge thickness at certain dostance from the edge 
 
Edge radius – calculates the edge radiis, taking into account points that are symmetrically disposed 
along the direction of the range, that will fall into the segment angle indicated. 
 
Stack X – best-fit X Translation 
 
Stack Y – best-fit Y Translation 
 
Twist – rotation obtained by the best-fit 
 
Max X, MinX, Max Y, Min Y – extremum points on the profile are found and reported 
 
Stack TP – true position of the stack axis (calculated from StackX and StackY values) 
 
Print – here we can select which kind of print template will be used. According to your need you 
can also de-activate this field. The evaluation will anyway create automatically different views, that 
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can be later combined in a personalized report “template”. The original templates can be also 
modified or new once can be added. 
 
Report Comment : Allows to insert a string that may be shown on the report (depending on the 
template). The template must contains a filed for TXT, with the name of TXT:CommentAirfoil 
 
The already available templates are : 
 

AirfoilReport1.xml 

Gloibal View 
LE View 
TE View 
Airfoil parameters table 

 

AirfoilReport1E.xml 

Concave side 
Coonvex side 
TE View 
LE View 
Airfoil parameters table  

AirfoilReport2.xml 
Gloibal View 
LE View 
TE View 

 

AirfoilReport3.xml Global View 

 

AirfoilReport4.xml 
Gloibal View 
TE View 
Airfoil parameters table 

 

AirfoilReport5.xml 
Gloibal View 
Airfoil parameters table 

 

AirfoilReport6.xml 

Gloibal View 
TE View 
LE View 
Linearized graph 
Airfoil parameters table  

AirfoilReportMaxGraph.xml Global View  
 
If desired a summary  report can be created. For doing this just select the “summary report”, then 
check the list of the sections to be reported and the list of the parameters to be reported (the 
Summary report will report the list of the parameters that you select in this moment, and will not 
refer to the existing dimensions!) 
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Notes about the modification/ creation of templates : Creating a new template, we must include in that template 
componenst (graphical fields, texts and dimension tables) in the desred position and with desired size. These 
componenst must have certain names (as long as it regards the graphs and the texts) and must be related to certain 
“family” as long as it regards the dimension tables. Here you find the necessary info: 
 
Graphs Texts 
GraphGlobal – complete profile (According to what has 
been selected in the “show” combo box) 
GraphGlobaCC – concave side 
GraphGlobalCV – convex side 
GraphTE – TE 
GraphLE – LE 
GraphGlobalLinear – Lienarized profileof the complete 
profile (pls. Set the  AutoAdjust property to 1) 

TextGlobal_1 – Info best-fit and ampl. error 
TextGlobal_2 – Data best-fit 
TextLE_1 – Info best-fit and ampl. error 
TextLE_2– Data best-fti 
TextTE_1 – Info best-fit and ampl. error 
TextTE_2– Data best-fit 
CommentAirfoil – comment on the report 

 
Dimension tables (any name, attention on the family!)  
Family5 (Stile 1) – Valori forma TE 
Family6 (Stile 1) – Valori forma LE 
Family7 (Stile 1) – Valori forma CC 
Family8 (Stile 1) – Valori forma CV 
Family9 (Stile 0) – Tabella parametri foglia 

 

 
All other compnents may have any name 
 
View of the template editor with the template AirfoilReport1.xml 
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5. Step-by-step guide for perfoming “blade” analysi s with PC-
DMIS and CA 
 
There are 4 important steps to execute 
 
Creation of the NOMINAL file 
 

- Create off-line scans in PC-DMIS applying high point density (using version 2009, yoiu can 
use the new “Cut Section” option) 

- Import the scan in CA (File -> Import -> Read from PC-DMIS) 
- Use eventually the “chord filetr error” (Menu Curve -> Curva 2D calcutaion) 
- Assign tollerance (Menu Curve -> Airfoil calculation -> Assign tollerance) 
- Change the name of the profiles (the neames will be shown in the reports!) and delete 

evntually unnecessary objects 
- Save the file (Menu File -> Save) 

 
Creation of the measurement path on the PC-DMIS PP 
 

- In PC-DMIS: execute the alignment 
- In PC-DMIS Activate the probe for measurement of the CONVEX side and position the 

probe on that side. Put the cursor on the bottom.  
- In CA: ensure having opened the nominal file, then go to “Measure” -> “Airfoil path 

generation”, Selectthe sections, then Select the position of the probe according to what you 
see in the CMM. (the physical position of the probe, not refffered to some axises), check the 
“move out value” (defualt is 50), and the probe diameter value, and  click on Generate. Wait 
until the scans are generated. (Keep the generation window opened). 

- In PC-DMIS : Execute the scans created by CA 
- In PC-DMIS : change the probe and add the necessary moves to go to the other side. Put the 

cursor on the bottom. 
- In CA: (we still have activated the “Airfoil path generation”), change the probe position 

(there is apecial button to invert the probe position “<->”) and clik on Generate. Wait until 
generation finisces adn close the window. 

- In PC-DMIS : Execute the scans created by CA 
-  

Creation of the macro 
 

- Go to CA: 
- Clean all (Menu “File” -> “New”) 
- Activate the MACRO registration 
- Import the scans form PC-DMIS  (Menu “File” -> “Import” -> “From PC-DMIS” 

(accordingto thepart program size may be needed to wait a bit, running the macro this time 
will be absent) 

- Collect the scans Menu “Curve” -> “Airfoil calculations” -> “Collect airfoil scans” 
Attention: for scans with low point density non use the “Sorting” option! 

- Load the nominals : Menu “File“ -> “Open”, respond with “No” on the question if the 
present data must be deleted and indicate the position of the nominal file 

- Execute the airfoil evaluations : Menu “Utilities” -> “Special calculations” -> “Airfoil 
evaluations”. Be careful on : 

o Names of Nominal and Measured  
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o Pre-processing data (enable the Radius compensation and indicate the RADIUS of 
the probe – for trigger point sensors, insert the “dynamic” radius of the probe) 

o Once you select the airfoil parameters you want to calculate, click on “Clculate 
nominals” and check the calculated nominals 

o Select the desired plot format 
o Click on OK for generating the evalaution 

Repeat this sequence with another secion, clciking on OK for cerating a new page  
- Go in “Page Viewer”  and selectthe PDF file name for the report  (Menu “File” -> “Set 

printer or PDF file name”). Selectthe name and eventuall add to the name the part data.. 
- Being in “Page Viewer” fo to “File” -> “Print all” (this action will create the PDF) 
- Turn back in CA go to “File” -> “exit” -> You will be asled for the name of the macro. Input 

some name. 
 
(Testing : If you make now File -> New, then access the macro, open the macro you just created, 
and run it – notet hat having recorder the “Exit” command in the macro CA will be closed at the 
end) 
 
Inserting recall to CA from PC-DMIS PP 
 

- In PC-DMIS: Ensure having some variables in PC-DMIS PP, that for axample hold the part 
number or other important data 

- In PC-DMIS: Move the cursor to the bottom  
- In CA: go to  menu “Utilities” -> “PC-DMIS Utilities” and select “Recall CA…”. Wait the 

window to be shown. Select the script option. Select the correspondanse of the PC-DMIS 
variables and the part data table in CA, select also the macro to run. Click on OK. This will 
create a command in PC-DMIS that will run CA, executin the macro. 

 
(Testing : Putthe cursor on the script command and press CTRL+U – CA will be opened and the 
macro will be executed) 
 

6. The “all-in-one” function for evaluating of para meters of 
airfoil sections for airscrews 
 
Function Access 
Airfoil evaluations propeller Utilities -> Calculation Utilities -> Airfoil evaluations 

propeller 
 
The “all-in-one” functions allws to perform complete evaluation on airfoil section of airscrew, 
producing also reporting page of it. It calculates only some parameters, that are used mainly for 
checking of Airscrews for maintenance purposes. In order to be recalled you must have in CA the 
following curves: 
 

� measured sections (can be radius corrected or not), must be complete sections 
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The evaluations are performed section per section (possible to create one page for report), and it is 
possible to select one of 3 possible profile types (sections near the hub, double convex sections, 
concave sections). Here is the list of the evaluated parameters 
 
Parameters Profile near the hub Double convex profile Concave profile 
Max. Width Max Width (airfoil) Max Width (airfoil) Max Width (airfoil) 
Chord length Outscribed circle 2D Distance from TE 

to LE  
2D Distance of 
extremum point, 
parallel to the contact 
line 

Angle NA Line from TE to LE Contact Line 
Face Align NA 2D Distance from 

origin, to the pierce 
point of a line  passing 
through the origin 
(perp. to LE/TE Line) 
with the profile  

2D Distance from 
origin, to the pierce 
point of a line passing 
through the origin 
(perp. to Contact Line 
) with the profile 

Edge Align NA 2D Distance from 
origin to the extremum 
point of the LE 

2D Distance from 
origin to the extremum 
point of the LE 

 
And here are the examples of produced report pages: 
 

Profile near the “hub” Double convex profile Concave profile 
 

 

 

 

 

 
 

 
At the end of the evaluation it is also possible to create a summary table like shown bellow 
 

 
 
Interface 
 
Here is the interface window: 
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• Select the section desired (will be shown immediately in the pre-view) 
• In some rare cases (very thin profiles where the automatic LE/TE recognition may fail) the 

indication of the LE direction is necesseary. Normally the automatic recognition works fine. 
• In the “Preparation” of measured data, a radius correction may be executed, or some “Clean-

up” of the source point can be requested. 
• In “Parameters” it is operator responsability to indicate the type of the section and to 

compile the min/max values of all parameters needed. For the “angle” dimension also 
“correction” value may be input (this value will be added to the calculated one. 

• In the “single report” you may check or unchek the generation of the single report. 
• Click on  OK – if the “single reports” was enabled then In “Page Viewer” a report page will 

be inserted. 
• Proceed with next section… 

 
After the last section, without exiting the window, you can access the “summary” report window 
and a sammary table may be created. 
 
All this commands are usually saved to a macro, so that the exection is automated. To edit the 
macro, please use the usual mode, opening the macro, then selecting a command and accessing the 
“edit window” with F9. After making the changes save the macro pressing F10 (while having focus 
on the “macro window” 
 


